Apr 30

[JunOS] Vlan Trunking Error : VLAN-ID must be specified on tagged ethernet interfaces

[Juniper Training Here]

fe-1/2/0 {
vlan-tagging;
unit 0 {
family inet;
}
unit 5 {
vlan-id 5;
family inet {
address 192.168.168.1/28 {
vrrp-group 1 {
virtual-address 192.168.168.2;
priority 200;
}
}
}
}
unit 6 {
vlan-id 6;
family inet {
address 192.168.168.17/28 {
vrrp-group 2 {
virtual-address 192.168.168.18;
priority 200;
}
}
}
}
}

- Error while trying to commit this – :
“VLAN-ID must be specified on tagged ethernet interfaces”
Action : Please define vlan-id for unit 0 !.

#set unit 0 vlan-id 0
#commit

a. rahman isnaini r.sutan

Feb 07

[Juniper] Copy Paste Configuration in JunOS – Load Replace / Load Merge Terminal

[Daily note]

As you can easily copy a configuration from a notepad/word/whatever to Cisco CLI command line, in JunOS should be easy as well.
Some options to paste the copied configurations are :

1. Replace the current configuration
“Load Replace Terminal Relative” then Enter
— Paste your configuration — then Enter
Ctrl D

Purpose : Replace the existing configuration with the new one and it can be on the global configuration or in a tree (let say under interfaces, under policy options, routing-options or what ever).

2. Merge the current configuration with the new one.
“Load Merge Terminal Relative” then Enter
— Paste your configuration — then Enter
Ctrl D

Purpose : Merge the existing configuration with the new one and it can be on the global configuration or in a tree (let say under interfaces, under policy options, routing-options or what ever).

Do not forget to commit check, compare, and a real commit command.

a. rahman isnaini r.sutan

Jan 20

[Juniper] Unstable/Flapping BGP Connection with Quagga Using Traffic Shaping / Ratelimiting

You might find this bgp error as captured on the bottom.
Right after BGP session if cleared either accidentally or administratively, it’s flapping (idle-openconfirm-opensent-establish-idle).

This might happened on a JunOS with rate-limit / traffic shapping configured.
What I have suspected, the bgp session needs a different allocation.

And it works.

filter CUSTOMER {
term BGP-TRAFFIC {
from {
protocol tcp;
source-port bgp;
}
then {
policer BGP-CUSTOMER;
count BGP-TRAFFIC;
}
}
term CUSTOMER-TRAFFIC {
then {
policer SHAPE-CUSTOMER;
count CUSTOMER-TRAFFIC;
}
}
}

policer SHAPE-CUSTOMER {
if-exceeding {
bandwidth-limit 1024000;
burst-size-limit 256k;
}
then discard;
}
policer BGP-CUSTOMER {
if-exceeding {
bandwidth-limit 3096000;
burst-size-limit 256k;
}
then discard;
}

– Juniper BGP Log Message –

Continue reading

Jan 17

[Juniper] Reflecting Route in JunOS from Cisco to Cisco in a iBGP Topology

-daily note-

Most of sample from Juniper is Reflecting routes from Juniper to Juniper.
How do we reflect route from Cisco to Cisco.
I’m not pretty sure that the configuration has be this way or it can be simplified.
All below config has worked pretty well, should you find another shorter on please kindly share.

At least, I cannot make any further change due to it’s already on production :)

Topology : CISCO[A]-(iBGP)-JUNIPER[B]-(iBGP)-CISCO[C]
Problem : Reflecting Routes from A to C (one way)
Action : Clustering Cisco A and C

Configuration :

group iBGP-REFLECTOR {
type internal;
local-address 192.168.235.185;
cluster 192.168.235.185;
neighbor 192.168.235.186 {
description ***iBGP-to-CISCO A***;
import CISCO-A-IMPORT;
export CISCO-A-EXPORT;
peer-as 65500;
}
}
group iBGP-INDONET {
type internal;
local-address 192.168.235.158;
cluster 192.168.235.185;
neighbor 192.168.235.157 {
description ***iBGP-to-CISCO C***;
import CISCO-C-IMPORT;
export CISCO-C-EXPORT;
peer-as 65500;
}
}

Ignoring other BGP policies, due to all we need to concern to CISCO-C-EXPORT (the rest is general).
I eventually have to add a term local (what ever it called) and redistributing neighbor 192.168.235.186 to CISCO-C
And it works.

policy-statement CISCO-C-EXPORT {
term connected {
from protocol direct;
then accept;
}
term static {
from protocol static;
then accept;
}
term local {
from {
protocol [ local bgp ];
neighbor 192.168.235.186; >>> this has be stated.
}
then accept;
}
term 2 {
from as-path SELF;
then accept;
}
term 4 {
from as-path ALL;
then reject;
}
}

Sorry, i didn’t follow juniper route reflection with the correct clustering configuration.

Enjoy your ordinary breaking.
I assume that you have good also in iBGP Route-Reflector-Client configuration.

a. rahman isnaini r.sutan